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Einführung in die digitale Bildanalyse mit ImageJ C3BL
⭳: laborberufe.de

Überblick

ImageJ ist  ein  plattformübergreifendes  Bildbearbeitungs-
programm  und  vor  allem  auch  ein  Bildver  arbeitugs-
programm: Nach der Bildbearbeitung (z.B. Kontrasterhöhung
der Farben) kann man die Daten des Bildes quantitativ aus-
werten (z.B. die Summe der roten Flächen bestimmen, Länge
von  Strukturen  bestimmen  etc.).  Es  wird  für  medizinische
und wissenschaftliche Bildanalyse genutzt, zum Beispiel das
Vermessen  von  Strukturen  auf  Mikroskopaufnahmen.  Die
Funktionalität  des  Programms  kann  durch  Hunderte  von
Plug-ins erweitert werden. Das Programm und der Quelltext
sind *frei (public domain, Open Source). Die Version Fiji von
ImageJ  (=  Fiji  is  just  ImageJ)  wurde initiiert,  um möglichst
viele  Werkzeuge  für  die  Analyse  von  Bildern  biologischer
Probenzu vereinen.   Dazu  wurde ImageJ um eine Vielzahl
von Plug-ins erweitert. 

Stickware: Auf USB-Stick überall mitnehmen

Sie  können Fiji  unter  https://imagej.net herunterladen.
ImageJ/Fiji ist portabel: Das Programm durchläuft also keine

Installationsroutine  o.ä.  Man  muss  die  zip-Datei  nur
entpacken,  z.B.  auf  einen  USB-Stick.  So  hat  man  das
Programm  überall  mit  dabei  (Stickware).  Am  besten
gemeinsam  mit  LibreOffice  auf  denselben  Massenspeicher
packen.  So  ist  man  voll  ausgestattet  und  jederzeit
einsatzbereit ;-)

• VORSICHT: Legen  Sie  ImageJ/Fiji  nicht  in  „C:\
Programme“ oder  einer  anderen  Systempartition
ab,  weil  dann  die  .exe-Datei  aufgrund  der
Sicherheitsrichtlinien keine Schreibrechte erhält und
so z.B. ein Update nicht möglich ist.

• Es gibt auch eine online-Version die sich direkt über
den Browser bedienen lässt, zur Not auch über das
Smartphone: 

https://imagej.net/software/imagej-js

1. Übung: Proteingelelektrophresen halbquantitativ auswerten

Hierfür gibt es ein gesondertes Arbeitsblatt: PAGE digital auswerten mit ImageJ: Quantitative Auswertung einer Elektrophorese 
(z.B. auf www.laborberufe.de) 

2. Übung: Fläche eines größeren Objektes bestimmen. Fotosynthetisch aktive (=grüne) Fläche eines Efeublattes

1. Laden Sie die Datei http://laborberufe.de/sonstiges/blatt.jpg herunter und öffnen Sie 
diese in ImageJ/Fiji. 

2. Bild in ein Graustufenbild umwandeln: → Image → Type → 8-bit

3. Maßstab festlegen. Hierfür wird das Lineal am oberen Rand genutzt. Zeichnen Sie mit 
dem Linien-Wekzeug (5. Button von links) dort einen 50 mm (= 5 cm) langen Strich. 
Öffnen Sie dann → Analyze → Set Scale. Geben Sie bei Known Distance 50 und bei Unit 
mm ein. Pixel aspect ratio: 1.0 Setzen Sie auch ein Hakten unter „Global“.

4. Machen Sie eine automatische Schwellenwert-Festlegung, d.h. legen Sie fest, welche 
der Farben/Graustufen nachher als Fläche erfasst wird.: Process → Binary →Make 
Binary. Nur die vormals grünen Flächen sollten jetzt weiß hervorgehoben sein. Alle 
anderen Flächen sind schwarz.

5. Fläche ermitteln: Mit Rechteckauswahl-Werkzeug (1. Button von links) gesamtes Blatt einkästeln. Dann unter → 
Analyze → Analyze Particles… bei Particle Size 50- eintragen. Damit wird festgelegt, dass nur Partikel (=Objekte) 
gewählt werden, die mindestens 50 mm² groß sind. Hierdurch wird erreicht, dass wirklich nur das gesamte Blatt als 1 
Objekt angesehen wird. Show auf Outlines festlegen, d.h. nachher soll die Kontur angezeigt werden.  Zum Schluss 
Display results mit Haken auswählen, damit die Ergebnisse angezeigt werden und OK anklicken. Im Results-Fenster 
sollte ungefähr die Fläche des grünen Bereichs angezeigt werden, um die 2000 mm². Fläche notieren!

6. Nun muss noch die Gesamtblattfläche bestimmt werden. Hierfür nochmal das original-Bild öffnen und in 8-bit-Fartife 

umwandelt (siehe oben). Nun mit → Image → Adjust →Threshold so die Schieber positionieren, dass die nun 
vollständige, d.h. die gesamte Blattfläche rot hervorgehoben ist und das Threshold-Fenster mit „x“ schließen.  Nun geht
es wieder weiter wie bei Schritt 5. Die Gesamtfläche des Blattes sollte rund um 2400 - 2700 liegen.

https://imagej.net/
http://laborberufe.de/sonstiges/blatt.jpg
http://www.laborberufe.de/
https://imagej.net/software/imagej-js
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7. Jetzt können Sie die prozentuale Grünfläche bestimmen. 

3. Übung: Partikelanalyse (Anzahl und Fläche)

2.1 Führen Sie die im youtube-Video https://youtu.be/9oMMcu-I3BY „Bildanalyse-Video-Kurs mit ImageJ

und GIMP - 6/7 (Beispiel 1)" (12 min) gezeigten Inhalte mit dem dort verwendeten Bild selber durch! Das 

Bild finden Sie unter http://laborberufe.de/sonstiges/  wachsteile  .jpg   .

Damit Sie nicht ständig hin und her klicken müssen, hier die Schritte stichwortartig: 

1. Bilddatei Wachsteile.jpg in ImageJ öffnen (→ File → Open….). Farbtyp reduzieren: → Image → Type → 8bit

2. Maßstablänge mit Linienwerkzeug nachzeichnen. Danach → Analyze → Set Scale...  Known Distance (=1) und Unit of 
length die Einheit (cm) angeben.

3. Analysebereich mit Rechteckauswahl-Werkzeug festlegen. Bereich mit einem klein Rechteck rund um die 
Maßstabsangabe davon abziehen lassen, durch gleichzeitige Benutzung der ALT-Taste

4. Schwellenwert (Threshold) festlegen: → Image → Adjust → Threshold → Alle zu berücksichtigenden Strukturen sollen 
kontrastreich und vollständig in rot zu erkennen sein. „Auto“ hilft für eine erste Grobeinstellung! Mit „x“ Threshold-
Fenster schließen.

5. Ausgabeparameter einstellen. →  Analyze → Set Measurements... → Nur Fläche (Area) auswählen.

6. Testlauf: → Analyze → Analyze Particles…. → Show: Outline. Bei Clear Results, Summarize und Display results Haken 
setzen und mit OK bestätigen.

7. Anzahl der registrierten Objekte ablesen und mit original-Bild vergleichen. Vergleich der Konturdarstellung mit dem 
Bild um zu prüfen, ob gerade die Objekte die registriert werden sollten, auch berücksichtigt wurden. 

8. Wenn die registrierte Objektanzahl noch nicht zufriedenstellend (=34) ist, alle Result- und Summary-Fenster schließen. 
Noch mal → Analyze → Analyze Particles auswählen um jetzt hier die Mindestgröße der zu registrierenden Objekte zu 
erhöhen. Pixel Units anklicken, da wir diese Einheit wählen (und nicht cm). Bei Size z.B. 20– eingeben (d.h. 
Mindestgröße der Objekte: 20 Pixels). Liefert das auch noch nicht ganz das gewünschte Ergebnis Threshold 
nachbessern (siehe 4.) nachbessern.

9. Wenn Analyseergebnis zufriedenstellen (34 Objekte) mit → Analyze →  Distribution ein Säulendiagramm mit der 
Flächenverteilung erzeugen (z.B. 10 Säulen = bins). Bei Range den Größenbereich auswählen. siehe Result-Fenster. z.B.
0 – 1.9.

10. Inhalt des Results-Fenster über File → Save as… abspeichern. Speicherformat: *.csv (comma separated values). 

11. CSV-Datei mit LibreOffice Calc importieren, so dass eine zweispaltige Tabelle (Laufnummer und Fläche in cm²) 
entsteht.

12.  In LibreOffice die Werte nach Größe sortieren. Daneben Klassen anlegen. Siehe Video ab Minute 7. Mit der Funktion 
„Häufigkeit“ sich die Anzahl der Objekte der jeweiligen Klasse anzeigen lassen. Danach Säulendiagramm erstellen.

4. Übung: Wie 3. Übung nur diesmal mit wirklich vielen Zellen

• Öffnen Sie das Bild http://laborberufe.de/sonstiges/  zellkolonie  .jpg   und analysieren Sie Größe und Anzahl der Zellen mit
den Methoden aus der vorangegangenen Übung.

5. Übung: Manuelles Zählen von Zellen an einem Differentialblutbild und einem Fiji-Plug-in

• Öffnen Sie das Bild http://laborberufe.de/sonstiges/  differentialblutbild  .  jpg    

• Starten Sie: Plugins → Analyze → Cell counter. Drücken Sie zuerst Initialize und zählen Sie die verschiedenen Zellen 
(aufgeschlüsselt nach unterschiedlichen Typen!) indem Sie unterschiedliche Counter nutzen. Lassen Sie sich nachher 
die Results anzeigen.

http://laborberufe.de/sonstiges/differentialblutbild.jpg
http://laborberufe.de/sonstiges/differentialblutbild.jpg
http://laborberufe.de/sonstiges/differentialblutbild.jpg
http://laborberufe.de/sonstiges/differentialblutbild.jpg
http://laborberufe.de/sonstiges/wachsteile.jpg
http://laborberufe.de/sonstiges/zellkolonie.jpg
http://laborberufe.de/sonstiges/wachsteile.jpg
http://laborberufe.de/sonstiges/wachsteile.jpg
http://laborberufe.de/sonstiges/wachsteile.jpg
http://laborberufe.de/sonstiges/wachsteile.jpg
https://youtu.be/9oMMcu-I3BY
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Überblick

ImageJ ist ein plattformübergreifendes Bild­bearbei­tungs­programm und vor allem auch ein Bildver­arbeitugs­programm: Nach der Bildbearbeitung (z.B. Kontrast­erhöhung der Farben) kann man die Daten des Bildes quantitativ aus­werten (z.B. die Summe der roten Flächen bestimmen, Länge von Strukturen bestimmen etc.). Es wird für medizinische und wissen­schaftliche Bildanalyse genutzt, zum Beispiel das Vermessen von Strukturen auf Mikro­skop­aufnahmen. Die Funktionalität des Programms kann durch Hunderte von Plug-ins erweitert werden. Das Pro­gramm und der Quelltext sind *frei (public domain, Open Source). Die Version Fiji von ImageJ (= Fiji is just ImageJ) wurde initiiert, um möglichst viele Werk­zeuge für die Analyse von Bildern biologischer Probenzu vereinen.  Dazu  wurde ImageJ um eine Vielzahl von Plug-ins erweitert. 

Stickware: Auf USB-Stick überall mitnehmen

Sie können Fiji unter https://imagej.net herunterladen. ImageJ/Fiji ist portabel: Das Programm durchläuft also keine Installationsroutine o.ä. Man muss die zip-Datei nur entpacken, z.B. auf einen USB-Stick. So hat man das Programm überall mit dabei (Stickware). Am besten gemeinsam mit LibreOffice auf denselben Massenspeicher packen. So ist man voll ausgestattet und jederzeit einsatzbereit ;-)

		VORSICHT: Legen Sie ImageJ/Fiji nicht in „C:\Programme“ oder einer anderen Systempartition ab, weil dann die .exe-Datei aufgrund der Sicherheitsrichtlinien keine Schreibrechte erhält und so z.B. ein Update nicht möglich ist.



		Es gibt auch eine online-Version die sich direkt über den Browser bedienen lässt, zur Not auch über das Smartphone: 





https://imagej.net/software/imagej-js

  

1. Übung: Proteingelelektrophresen halbquantitativ auswerten

Hierfür gibt es ein gesondertes Arbeitsblatt: PAGE digital auswerten mit ImageJ: Quantitative Auswertung einer Elektrophorese (z.B. auf www.laborberufe.de) 

2. Übung: Fläche eines größeren Objektes bestimmen. Fotosynthetisch aktive (=grüne) Fläche eines Efeublattes

				Laden Sie die Datei http://laborberufe.de/sonstiges/blatt.jpg herunter und öffnen Sie diese in ImageJ/Fiji. 



		Bild in ein Graustufenbild umwandeln: → Image → Type → 8-bit



		Maßstab festlegen. Hierfür wird das Lineal am oberen Rand genutzt. Zeichnen Sie mit dem Linien-Wekzeug (5. Button von links) dort einen 50 mm (= 5 cm) langen Strich. Öffnen Sie dann → Analyze → Set Scale. Geben Sie bei Known Distance 50 und bei Unit mm ein. Pixel aspect ratio: 1.0 Setzen Sie auch ein Hakten unter „Global“.





		



				Machen Sie eine automatische Schwellenwert-Festlegung, d.h. legen Sie fest, welche der Farben/Graustufen nachher als Fläche erfasst wird.: Process → Binary →Make Binary. Nur die vormals grünen Flächen sollten jetzt weiß hervorgehoben sein. Alle anderen Flächen sind schwarz.





		





		Fläche ermitteln: Mit Rechteckauswahl-Werkzeug (1. Button von links) gesamtes Blatt einkästeln. Dann unter → Analyze → Analyze Particles… bei Particle Size 50- eintragen. Damit wird festgelegt, dass nur Partikel (=Objekte) gewählt werden, die mindestens 50 mm² groß sind. Hierdurch wird erreicht, dass wirklich nur das gesamte Blatt als 1 Objekt angesehen wird. Show auf Outlines festlegen, d.h. nachher soll die Kontur angezeigt werden.  Zum Schluss Display results mit Haken auswählen, damit die Ergebnisse angezeigt werden und OK anklicken. Im Results-Fenster sollte ungefähr die Fläche des grünen Bereichs angezeigt werden, um die 2000 mm². Fläche notieren!



		Nun muss noch die Gesamtblattfläche bestimmt werden. Hierfür nochmal das original-Bild öffnen und in 8-bit-Fartife umwandelt (siehe oben). Nun mit → Image → Adjust →Threshold so die Schieber positionieren, dass die nun vollständige, d.h. die gesamte Blattfläche rot hervorgehoben ist und das Threshold-Fenster mit „x“ schließen.  Nun geht es wieder weiter wie bei Schritt 5. Die Gesamtfläche des Blattes sollte rund um 2400 - 2700 liegen.



		Jetzt können Sie die prozentuale Grünfläche bestimmen. 





3. Übung: Partikelanalyse (Anzahl und Fläche)

		2.1 Führen Sie die im youtube-Video https://youtu.be/9oMMcu-I3BY „Bildanalyse-Video-Kurs mit ImageJ und GIMP - 6/7 (Beispiel 1)" (12 min) gezeigten Inhalte mit dem dort verwendeten Bild selber durch! Das Bild finden Sie unter http://laborberufe.de/sonstiges/wachsteile.jpg .

Damit Sie nicht ständig hin und her klicken müssen, hier die Schritte stichwortartig: 

		  





		Bilddatei Wachsteile.jpg in ImageJ öffnen (→ File → Open….). Farbtyp reduzieren: → Image → Type → 8bit



		Maßstablänge mit Linienwerkzeug nachzeichnen. Danach → Analyze → Set Scale...  Known Distance (=1) und Unit of length die Einheit (cm) angeben.



		Analysebereich mit Rechteckauswahl-Werkzeug festlegen. Bereich mit einem klein Rechteck rund um die Maßstabsangabe davon abziehen lassen, durch gleichzeitige Benutzung der ALT-Taste



		Schwellenwert (Threshold) festlegen: → Image → Adjust → Threshold → Alle zu berücksichtigenden Strukturen sollen kontrastreich und vollständig in rot zu erkennen sein. „Auto“ hilft für eine erste Grobeinstellung! Mit „x“ Threshold-Fenster schließen.



		Ausgabeparameter einstellen. →  Analyze → Set Measurements... → Nur Fläche (Area) auswählen.



		Testlauf: → Analyze → Analyze Particles…. → Show: Outline. Bei Clear Results, Summarize und Display results Haken setzen und mit OK bestätigen.



		Anzahl der registrierten Objekte ablesen und mit original-Bild vergleichen. Vergleich der Konturdarstellung mit dem Bild um zu prüfen, ob gerade die Objekte die registriert werden sollten, auch berücksichtigt wurden. 



		Wenn die registrierte Objektanzahl noch nicht zufriedenstellend (=34) ist, alle Result- und Summary-Fenster schließen. Noch mal → Analyze → Analyze Particles auswählen um jetzt hier die Mindestgröße der zu registrierenden Objekte zu erhöhen. Pixel Units anklicken, da wir diese Einheit wählen (und nicht cm). Bei Size z.B. 20– eingeben (d.h. Mindestgröße der Objekte: 20 Pixels). Liefert das auch noch nicht ganz das gewünschte Ergebnis Threshold nachbessern (siehe 4.) nachbessern.



		Wenn Analyseergebnis zufriedenstellen (34 Objekte) mit → Analyze →  Distribution ein Säulendiagramm mit der Flächenverteilung erzeugen (z.B. 10 Säulen = bins). Bei Range den Größenbereich auswählen. siehe Result-Fenster. z.B. 0 – 1.9.



		Inhalt des Results-Fenster über File → Save as… abspeichern. Speicherformat: *.csv (comma separated values). 



		CSV-Datei mit LibreOffice Calc importieren, so dass eine zweispaltige Tabelle (Laufnummer und Fläche in cm²) entsteht.



		 In LibreOffice die Werte nach Größe sortieren. Daneben Klassen anlegen. Siehe Video ab Minute 7. Mit der Funktion „Häufigkeit“ sich die Anzahl der Objekte der jeweiligen Klasse anzeigen lassen. Danach Säulendiagramm erstellen.





4. Übung: Wie 3. Übung nur diesmal mit wirklich vielen Zellen

		Öffnen Sie das Bild http://laborberufe.de/sonstiges/zellkolonie.jpg und analysieren Sie Größe und Anzahl der Zellen mit den Methoden aus der vorangegangenen Übung.





5. Übung: Manuelles Zählen von Zellen an einem Differentialblutbild und einem Fiji-Plug-in

		Öffnen Sie das Bild http://laborberufe.de/sonstiges/differentialblutbild.jpg  



		Starten Sie: Plugins → Analyze → Cell counter. Drücken Sie zuerst Initialize und zählen Sie die verschiedenen Zellen (aufgeschlüsselt nach unterschiedlichen Typen!) indem Sie unterschiedliche Counter nutzen. Lassen Sie sich nachher die Results anzeigen.
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